Dat Files

Started by Alex, January 07, 2011, 09:59:07 PM

Previous topic - Next topic


Hi All, hope some one can help. On trying to open up the RV Place Program to load a job, it comes
up with a message that I must create Dat Files before I can load a job. >:(

This coinsides with the Time Clock Battery going flat over the Xmas period as the Time and Date
was also lost. >:(

The Dat folder is there and contains 4 files, the question is how do I create the Dat files it asks for ???

Any help would be greatly appreciated.

Thanks in advance.


The important file is RVDATA.DAT which contains machine-specific calibration information, so the only way to create a new one if the file is lost is with a full recalibration. 
There are also backup versions of the file with .bak and .sav extensions - I don't recall under what circumstances these are saved - looking at the timestamps may give a clue.

If  RVDATA.DAT is there :

Maybe the RTC battery has also messed up some other BIOS info, or something is getting confused by a strange time/date - this sounds like some sort of OS/PC issue causing the software not to be able to see the file. Check that the RVDATA.DAT file doesn't have a wierd timestamp caused by the RTC issue. Also check the file is readable - it's plain text.

Could it be that it was set up with the DAT folder  on a non-default drive, and the CMOS setup has lost some drive info making that drive inaccessible?
The file rvplace.cfg in the software install folder specifies where it thinks the folder structure should be. 
The only other small possibility  I can think of is that the CMOS settings related to things like the controller cards (e.g PCI configuration) have changed, and the error is actually somewhere other than the .DAT file.


Hi Mike thanks for quick response, the File is there but it does have a strange Time/Date stamp.


Hi Mike, your a star, it turned out to be that the rvplace.cfg file was telling it to look for the files
on the A drive  ???.... why I have no clue.

But many many thanks for your help. ;D


Hi everybody. As you can guess, I just got my RV4s (first time dealing with P&P) and shortly after I messed up something:
When I try to start RVplace, I get the message "Invalid DAT file. Will load the default DAT file" and the next message is "Could not locate DAT file" and closing down the software.
The DAT files are there and the time and date stamps are correct.
Prior the problem I created a sub-folder "Old Files" into JOB folder and moved all old jobs from previous owner there. But then tried to open one old job file to see how they have done things and since then no happiness anymore!
I did change Rvplace config file to point to existing file in JOB folder, but still no happiness.
I will appreciate any ideas what else I can do to get it going again.
Thank you.


I'm guessing it can't find RVDATA.DAT or MCDATA.DAT on startup. Maybe you moved some other things while moving stuff around....
If all else fails find a utility online called filemon - this will show what files it is trying to find


Thanks Mike.
I did what you suggested. It is strange that it is looking for:
While RVDATA.DAT is in DAT folder, which is in RV folder (not in JOB folder), and I don't have CONFIG.DAT anywhere in my PC.
My RVPLACE.CFG file reads as follow:
Is it what supposed to be?
I didn't dare to do things I don't understand, so I run out if ideas. Isn't there way to re-install RVplace software from the beginning?


Mine looks like this - I assume the .job file is just the last used. Looks like you shouldn't have the JOB directory in the first path



Mike, thank you very very much! You were 100% right! It was this \JOB directory in the first path. I don't know how it got there, but after I removed it from Rvplace.cfg, my machine is working again. ;D
Thank you! Very useful forum!