Mike's Forums

Versatronics RV series Pick & Place machines => RV Hardware => Topic started by: Sixexe on March 27, 2016, 09:55:44 PM

Title: Z axis Dropping
Post by: Sixexe on March 27, 2016, 09:55:44 PM
I would be interested in anybody's thoughts.  From time to time (maybe once in 300 places) control of the Z axis appears to be lost and the tool is dropped, rather than lowered down, which inevitably damages the tool, the machine automatically recovers from the glitch and continues to place.  I have found that by reducing the Z speed from fast to medium the fault never occurs, but it would be nice to be able to use the machine at full speed.  Any ideas?
Title: Re: Z axis Dropping
Post by: phonoplug on March 27, 2016, 11:48:24 PM
One of the machine's very annoying 'features', that. I think its response to finding something unexpected (possibly with any axis, possibly just the Z) is to let go of the motor controlling Z and of course gravity then takes off at high speed towards whatever is below.

The difficult part is identifying what actually caused the problem. As far as I can tell, if it hits the Z top travel sensor unexpectedly this is its response. However, there are many things that can cause it to hit the sensor when its not expecting to. Possibly the most common is having the height or position of a component set incorrectly. As a result when it goes to pick up or place the part in question, it hits something and Z motor loses a few steps. Next time it raises the Z axis it goes higher than expected and if it then activates the sensor it drops the head.

Another scenario is where the X or Y axis has a fault of some sort and misses some steps. Net result is often it picking up from the wrong place, hitting something it wasn't expecting and continue as above. This is the problem I had and it took me ages to work out! In the end it was wires coming loose in the IDC connectors onto the motor drive cards (Y axis specifically).

If you're finding this happens every 300 placements or so thats a pretty critical problem worth the time to investigate I'd say.
Title: Re: Z axis Dropping
Post by: Gopher on March 30, 2016, 09:29:13 AM
Every 300 parts is a awful lot, this symptom sounds somewhat similar to what preceded us changing the Arm control board and the one in the PC (DSP Carrier?) with phonoplug's ones. In that instance I was fairly convinced it was losing XY position before dropping Z (it is a while a go now but I see to recall a distinct change in sound right before it went batshit). The new boards made the problem go away completely but it was nowhere near as frequent as every 300 parts more like 2-20K which for us was bad enough given it is quite capable of destroying a PCB depending on where it drops.
The replacement boards were a complete stab in the dark as we couldn't find any dodgy control lines or loose / faulty sensors, but it seems unlikely the same thing would go wrong twice assuming this is still that machine.
Title: Re: Z axis Dropping
Post by: Mike on March 30, 2016, 03:21:47 PM
Could it be a dodgy Z-axis limit switch - I don't recall if its an opto or mechanical, but if the former, maybe an aging LED giving a marginal signal ?
Title: Re: Z axis Dropping
Post by: phonoplug on March 30, 2016, 03:39:59 PM
Anything's possible, but I think sensor problems would tend to give you the opposite - position not found errors.
Title: Re: Z axis Dropping
Post by: Mike on March 30, 2016, 03:52:29 PM
I'd normally agree, but if it is a beam-break sensor, then an aging LED could plausibly cause random false actuations.
You could probaby diagnose this by reducing LED current slightly and watching the output to see how much margin there is. 
Title: Re: Z axis Dropping
Post by: spiyda on February 12, 2017, 07:11:06 PM
I've suddenly got this problem on both of my machines !

I can only run one machine at a time as I've only got one cabinet and one set of feeders
but the problem has now occurred on both.

One has a switched mode power unit, the other is a twin toroidal unit.

I've run on slow speed to try and see the issue..  but the problem randomly occurs in slightly different ways..

a)   the z axis suddenly dropped whilst over a feeder and wiped out the nozzle and broke a whole lot of cover tapes
This has happened while picking from feeders A and B
(it happened three times in one evening, which to say the least is a bit frustrating !)

b)   the machine dropped a component from about 3cm above the board and carried on as if nothing was wrong.
(this isn't as bad as the nozzle survives)

I posted here because oddly enough, its about every 300 or 400 components !

I thought I'd have found the issue by process of elimination, but not so far..


replaced the two main drivebelts
cleaned the x and y opto sensors
changed the z axis end opto sensor
reseated all the connectors in the arm
checked the rack and pinion for any play (yes there is some, but not enough to miss steps)
checked the connectors on each end of the machine to power unit.
checked the cables with a meter.
checked the PSU capacitors
changed the driver module in the power unit.
run with the network disconnected
exchanged all the connection cables
run armtest.exe and checked for glitches with the arm in all positions, wiggling the cables etc.
swapped the stepper drivers around
swapped the dsp boards around

I've checked all the motor driver settings on both my power units and they match "George04"'s wiring diagram except that all the drivers on both power units are set to 50% current rating when stopped. I Imagine this is to reduce heat.

Currently testing using the later switched mode PSU which is running at a steadt fairly clean 37V

In the latest run, the z axis behaved itself until the last couple of components, but got a bit lost, seemingly thinking it was lower than its actual position, and released the components from about 2cm.

running out of ideas  ..  any thoughts

ps  I'm not quite sure why the power down input on the stepper drivers is connected.
I can't think of any situation where the steppers would need the power cut other than the main power reset.
Title: Re: Z axis Dropping
Post by: Sixexe on February 17, 2017, 12:31:08 PM
I'm not entirely sure if my original 'Z axis Dropping' problem is resolved but it has not happened in recent weeks.  I still have a lot of my CDF files with Z axis speed set to medium but I have just run an old job which had CDF's with fast Z axis and has been OK.

I did however have other problems which in rectifying may have fixed the Z axis issue.  The first was the arm would freeze part way through a job and the machine would need to be restarted, this was eventually resolved after a lot of investigation by re-seating the ISA card (slide it in and out a few times to clean the contacts).

The other issue which I think is the more probable fix was that the Z axis started making a slightly different noise and the head started to punch components through the tapes instead of picking them up.  This was due to rack wear,  I didn't have a replacement to hand so I turned the rack around as the pinion doesn't contact the full width and the wear is just on one half (strange design!).  Doing this fixed the problem and may have fixed the Z axis drop problem as well.  To prove this I will have to edit my CDF's back to high speed on my regular jobs and let you know.

I have since ordered new rack and new pinions so that I will have spares to drop in when the current rack and pinion wears out completely.  The new parts I ordered will need some machining to make them fit which I will do when time permits.
Title: Re: Z axis Dropping
Post by: spiyda on February 17, 2017, 09:14:54 PM
Since my last post I've

pulled the ISA card, and reseated it
changed the rack and pinion (with custom spacers to get the maximum engagement)
changed the ram in the PC

re-calibrated the feeder and tool positions

swapped a couple of components from one camera to the other ( I'd been meaning to do that as the smaller components image better on the on-the fly camera, due to my threshold settings)

and put a switch in the pin 9 connection of the "Z" axis stepper driver CN1B
I don't even know if its connected to anything the other side of the power board , but it seemed like a no brainer.
(this is the pin that when active, turns off all power to the "Z" axis)

I ran a few boards this afternoon and managed to put components on, with just a couple of retries where the feeder pulled back

On the last run, the "Z" axis made that horrible noise when changing nozzles that is does just before wiping out a nozzle...
but this time, the machine recovered, reset the "Z" axis and carried on to finish placing all components.

My opinion is that the method for mounting the rack and the "Z" axis stepper motor to get the pinion to mesh properly with the rack leaves a lot to be desired.
There is no means of adjustment ...     that may change in the next day or two, the easiest will be to make the rack mounts adjustable as the stepper motor mounts are harder to get to.
There is more than enough room to do something a bit more sophisticated...

Fingers crossed its on the way to working properly again.
Title: Re: Z axis Dropping
Post by: Mike on February 18, 2017, 12:01:07 AM
I wonder if maybe a worn rack needs more torque to move it due to the gear tooth profile changing, and this is causing the motor to miss steps.
Title: Re: Z axis Dropping
Post by: spiyda on February 18, 2017, 12:55:27 AM
Placed about 5,000 components today with no errors, and just a few retrys (due to the normal feeder misbehaviour)
planning on placing probably 5,000 tomorrow, so fingers crossed.

It turns out the one bit of odd behaviour (the odd noise when nozzle changing) was the brass ring coming loose in nozzle No2.
I'm not sure of the exact sequence, but when this happened, the "Z" axis got a bit out of step but reset itself automatically. (finding the "Z" limit switch slowly)

Going back to the rack and pinion, the one fitted to the machine I am using is 6mm thick but the pinion only runs in 3mm
The pinion would foul on the linear bearing support block if this was increased, I doubt you could find more than an extra 0.5mm

More worrying is that there is a good 0.5mm play between the rack and pinion, easy to tell by trying to move the head up and down with the stepper powered up.
After a second look at it, adjustment could be provided by slotting the lower stepper motor mount, there is just enough space for the stepper to skew inside the arm.
I may do this on my spare machine.

I can't tell if there is any gradual acceleration programmed into the steppers, it doesn't sound like there is, maybe that's why the motors are all larger than would be fitted in modern equipment ?

Title: Re: Z axis Dropping
Post by: telted on March 21, 2017, 05:09:14 PM
Recently, we've had a few problems with our RV4S the worst being many nozzle crashes through the Z axis dropping. A different error was when the machine started up with a 'waitnotbusy' error message prior to the arm startup sequence and warm up routine. More error messages followed and ended with an 'R Axis Move Error' message, during all this the arm did not move at all.

Switched off, dismantled the PC and removed the RV ISA card. Re-seated all the ISA card sub boards contacts by wiggling them a lot and re-inserted the ISA card into the PC a few times to clean the edge connector contact surfaces. Re-assembled and the RV4s ran properly with no startup error messages. It seems this fixed the 'R Axis Move Error' problem.

Went on to place around 3000 components and then the nozzle crashed, (lowered nozzle hitting the front of a feeder hard and snapping off the tip, as usual). So, the above didn't fix the Z axis dropping problem.

Since replacement nozzles seem to be pretty much unavailable now, we have had to resort to making our own using our 3D printer. This is quite time consuming as the nozzle has to be made in two parts and then solvent welded together and finally drilled and matte black coated.

Read spiyda's comments about fitting a switch in the pin 9 connection of the "Z" axis stepper driver CN1B and thought it might be worth a try. After working out which CN1B board it was using George04's wiring diagram (turned out to be 1st board on the left), we fitted an on/off switch on the wire going to pin 9 and set it to the off position. Started up the RV4S and went on to place over 4000 components without a single nozzle crash.

However, we started to see that only some of the components on one particular feeder lane (G0) were being placed - the same lane where previously the nozzle crashes occured. When we checked the status for that lane the machine reported 'Feeder not reachable' and the 'No Entry' style symbol appeared against that lane. Tried to reset the bias but 'Feeder not reachable' kept coming up. Had to set 1st Ref for that feeder followed by selecting 'Yes' to 'Resetting all the biases' to clear the feeder not reachable problem. This was a pain as we had to set the biases for all the other lanes again.

Still, this was much better than crashing nozzles! However, the 'Feeder not reachable' error kept occurring too frequently until it was happening on every board.
At this point we moved the problem lane to another feeder and this seemed to solve the problem. Went on to place over 20,000 components with no nozzle crashes or 'Feeder not reachable' errors.

I think our problem was slightly different from spiyda's in that our z axis drop was being caused by an x/y axis error instead of a z axis worn rack problem, but the same 'switch-off the power' to the z stepper via pin 9 was causing the nozzle crashes. Anyway, thank you spiyda for steering us in the right direction and I hope our experience can be of some use to others.

Title: Re: Z axis Dropping
Post by: spiyda on March 23, 2017, 09:12:31 PM
@ telted

fingers crossed..   

and try gluing the broken bits of nozzle with Loctite 410
I was amazed they were strong enough to use on the machine within 30 minutes... 
I managed to save most of the broken ones for a second life

I've still got my doubts as to whether pin 9 is actually connected to anything,
however, my theory is that if the machine thinks it is, adding a switch it may fool the machine into behaving..

on a plus note, since adding the switch, zero "Z" axis crashes,  100,000+ components